Back to overview
Maintenance

Ubuntu Update

May 18, 2026 at 6:00pm UTC  –  May 18, 2026 at 7:00pm UTC
Affected services
Website
Teamspeak 3 Server
SEL Hosting VPS

Resolved
May 18, 2026 at 7:00pm UTC

Maintenance ended

Created
May 18, 2026 at 6:00pm UTC

Due to recent updates, we need to turn off services that run on the OVH Virtual Machine for South East London RPC. During this time all bot and web services will be offline. We expect this update to take a maximum of 1 hour.